Integrated Information Management System for Coastal and Marine Environment

IIMS User Manual

GEF/UNDP/IMO Regional Programme on Building Partnerships in Environmental Management for the Seas of East Asia
10. Definition of Terms

**Attribute** — a discrete element of data; not usually broken down into a smaller unit; it describes an entity and contains the entity’s data to be stored; and it becomes a column in a table.

**Data** — a general term meaning the numbers, facts, letters and symbols processed by a computer or a communication system to produce information.

**Database** — an organized collection of related files or tables for a common purpose.

**Entity** — something in the real world that is represented in a data model and about which data must be stored. It is a basic building block in a data model.

**Information** — data transformed into form and content relevant to a particular situation.

**Instance** — a particular occurrence of an entity.

**Many-to-many relationship** — A relationship between two entities in which one instance in the first entity can be related to many instances in the second entity, and one instance in the second entity can be related to many instances in the first entity.

**One-to-many relationship** — A relationship within a single entity in which one instance in the entity can be related to many instances in the same entity.

**Primary key** — an attribute selected as a unique identifier of a row in a table. Usually, it is one or more of the attributes of an entity that uniquely distinguishes that entity.

**Relational database** — a database consisting of relations or tables.

**Relational database management system** — a software that organizes, manipulates and retrieves data stored in a relational database.
Integrated Information Management System for Coastal and Marine Environment

User Manual
The Global Environment Facility/United Nations Development Programme/International Maritime Organization Regional Programme on Building Partnerships in Environmental Management for the Seas of East Asia (PEMSEA) aims to promote a shared vision for the Seas of East Asia:

“...the resource systems of the Seas of East Asia are a natural heritage, safeguarding sustainable and healthy food supplies, livelihood, properties and investments, and social, cultural and ecological values for the people of the region, while contributing to economic prosperity and global markets through safe and efficient maritime trade, thereby promoting a peaceful and harmonious co-existence for present and future generations."

PEMSEA focuses on building intergovernmental, interagency and intersectoral partnerships to strengthen environmental management capabilities at the local, national and regional levels, and develop the collective capacity to implement appropriate strategies and environmental action programs on self-reliant basis. Specifically, PEMSEA will carry out the following:

• build national and regional capacity to implement integrated coastal management programs;
• promote multi-country initiatives in addressing priority transboundary environment issues in sub-regional sea areas and pollution hotspots;
• reinforce and establish a range of functional networks to support environmental management;
• identify environmental investment and financing opportunities and promote mechanisms, such as public-private partnerships, environmental projects for financing and other forms of developmental assistance;
• advance scientific and technical inputs to support decision-making;
• develop integrated information management systems linking selected sites into a regional network for data sharing and technical support;
• establish the enabling environment to reinforce delivery capabilities and advance the concerns of non-government and community-based organizations, environmental journalists, religious groups and other stakeholders;
• strengthen national capacities for developing integrated coastal and marine policies as part of state policies for sustainable socio-economic development; and
• promote regional commitment for implementing international conventions, and strengthening regional and sub-regional cooperation and collaboration using a sustainable regional mechanism.

The twelve participating countries are: Brunei Darussalam, Cambodia, Democratic People’s Republic of Korea, Indonesia, Japan, Malaysia, People’s Republic of China, Philippines, Republic of Korea, Singapore, Thailand and Vietnam. The collective efforts of these countries in implementing the strategies and activities will result in effective policy and management interventions, and in cumulative global environmental benefits, thereby contributing towards the achievement of the ultimate goal of protecting and sustaining the life-support systems in the coastal and international waters over the long term.

Dr. Chua Thia-Eng
Regional Programme Director
PEMSEA
# Table of Contents

Acknowledgements

1. Introduction 1

2. Installing IIMS 1
   - Minimum System Requirements 1
   - Installation 2
   - Removing an Existing IIMS Setup 3
   - Saving Existing Data 3
   - Updating the IIMS Version 4

3. Opening IIMS Encoding Software 6

4. IIMS Main Window 7
   - Main Menu 7
   - File Menu 8
   - Edit Menu 9
   - View Menu 9
   - Query Menu 10
   - Launch Menu 11
   - Help Menu 11

5. Buttons 12
   - The Edit Buttons 12
   - The Navigational Buttons 12
   - Tab Controls 13
   - Entry Forms and Fields 13
   - Graphics Buttons 14
   - Memo Field 15

6. Operation 15
   - IIMS Region, Sites, Data Classes, Glossarial 17
   - Biological and Bioresources Categories 18
   - Socioeconomic Category 19
   - Demographic Data 20
   - Institutional Data 21
   - Pollution Sources Data 22
   - Monitoring Data 24
   - Physiographic Data 25
   - Model Data Inventory 27

7. Import Functionality 28
   - Tips on Importing Digital Files 31

8. Query Functionality 32
   - SQL Builder 32
   - Predefined Query 46

9. Linking IIMS to External Software Applications 49
   - Connecting IIMS and GIS through Data Source Open Database Connectivity 49
   - Setting the Launch Directory 50
   - Linking with a Predictive Model: SeaInfo 51
   - Linking with ArcView 3.x 52
Acknowledgements

The IIMS User Manual was developed by the PEMSEA Regional Programme Office's IIMS Technical Support Group consisting of Ms. Bresilda M. Gervacio, technical officer; Mr. Noel Robles and Mr. Alexis Fabunan, former GIS technicians; and Mr. Albert Cariño, programmer.

This Manual was tested at the various PEMSEA parallel and demonstration sites. The efforts of the IIMS Teams at the PEMSEA sites are gratefully acknowledged.

The assistance provided by RPO staff in finalizing this manual is highly appreciated.

Likewise, special thanks go to Mr. S. Adrian Ross, Dr. Huming Yu, and Dr. Jihyun Lee, senior programme officers, for their advice in completing this document. The unfailing support of Dr. Chua Thia-Eng, regional programme director, is very much appreciated.
1. **Introduction**

The Integrated Information Management System for Coastal and Marine Environment (IIMS) is a desktop database application, which manages a relational database of environmental data. The objectives of the IIMS include:

- standardizing data collection and recording;
- improving the quality and uniformity of the data collected; and
- integrating data into a common software system for time-effective and cost-effective analyses.

IIMS will provide timely data recording and updating of information for management and technological intervention, and to facilitate data sharing via the Internet. The data recording specifications is discussed in detail in the *Guide to Establishing IIMS*.

The IIMS software enables storage, display, query and report generation of environmental data. It is also capable of viewing and producing graphical presentation.

This manual deals with easy-to-follow steps and tips for encoding data, generating reports through query system and linking IIMS with external applications such as GIS and predictive models.

2. **Installing IIMS**

**Minimum System Requirements**

To install and run IIMS, the following minimum system requirements should be met:

1. Intel Pentium III
2. Windows 98, 2000 or XP
3. Memory 256 MB RAM
4. 500 MB of free hard disk space
5. CD-ROM Drive
6. SVGA (800 x 600)
7. Mouse or other pointing device
8. Scanner (preferably color)
Installation

1. Insert the installation CD in the CD drive.
2. Click **Start**.
3. Click **Run**.
4. On the **Run** window, click the **Browse** button.
5. Navigate the CD drive.
6. Double-click on the directory of the site you want to install in (i.e., double-click the Nampho directory for Nampho site installation)
7. Double-click **Setup**.
8. Click **OK** to start the installation.
9. Follow the instructions on the installation wizard. You can accept default values by clicking **Next** for each window prompt. Be sure to remember the destination folder of the new installation. The installation would only take a few minutes depending on the speed of your computer and the availability of space in your hard drive.
10. After the installation, a shortcut will be created. You can drag the shortcut (or get a copy) on the desktop for easier access to the program.
11. If you decide to launch the program after the installation, the system will ask for a username and a password. Type **iims** (initial username and password) to log into the system.

If there is an existing IIMS software installed in your computer, remove or rename the existing system prior to reinstalling IIMS. Refer to the **Removing an Existing IIMS Setup** section for instructions on removing the previous setup, then proceed installing the new version of IIMS.

To restore data from the previous installation, refer to the section on **Import Functionality**.

To populate the new installation with existing data from the previous installation, please refer to the **Saving Existing Data** procedure.
Removing an Existing IIMS Setup

It is not advisable to remove an existing IIMS setup of a previous version installed unless you are sure that there are no existing data stored. Be sure to ask the IIMS administrator if data has been added to the current IIMS installation (or individually check each table in the IIMS). To save the encoded data, follow the steps below on saving existing encoded data and then proceed with the following instructions for removing the system.

1. Click Start.
2. Go to Settings then Click Control Panel.
3. Double-click Add/Remove Programs.
4. In the Install/Uninstall tab, click iims from the list of available programs. If iims is not listed, then it is likely that it is not installed. Close all windows and proceed with the installation.
5. Click the Add/Remove button.
7. Wait for the deletion of associated files. Click Yes To All to remove all shared files. Then click Yes to proceed. On some instances, the computer will ask you to restart the computer. Click the No, I will restart the computer later option and press Next.
8. Click OK after the program has been successfully uninstalled.
9. Click OK to exit from Add/Remove Programs.
10. Close the Control Panel.

Saving Existing Data

1. Open IIMS program and browse through all the tables. List down all the tables with encoded data.
2. Create a directory on your hard drive that will contain the existing data.
3. Go to the View menu and click on a table from your list.
4. Under the File menu of the table window, go to Export then click to MS Excel file (or to Text file if you do not have Microsoft Excel).
5. Save the file with the same name as the table on your newly created directory (e.g., Muncity.txt for Muncity.db to easily remember where it should be added afterwards).

6. Repeat steps 3 to 5 until all tables in the list are already exported.

7. After all tables are saved, continue erasing the current IIMS installation.

Updating the IIMS Version

1. Using the Borland Database Engine (BDE) Administrator in the Windows Control Panel, change the path of the IIMS dat folder where the data will be transferred.

2. Open the IIMS transfer.exe in the installation CD.

3. Select the directory of the old IIMS database. Once selected, click the Merge Data button.
4. When the fields of the old tables/forms (source) and the new tables/forms (destination) are displayed, match the corresponding source and destination fields. Once selected, click the red right arrow. The selected fields will be displayed under the connected fields pane. If the selection is completed or either the source or the destination is empty or both, click **OK**.

5. Repeat steps 3 and 4 until all the forms are finished. Once database merging is completed, click the **Close** button.

**Note:** Forms that were not revised or have the same fields for both source and destination will have their data automatically transferred to the new IIMS. If the fields from the source and the destination match in terms of order, click the blue right arrow to transfer all the matched fields into the connected field pane.
3. **Opening the IIMS Encoding Software**

The IIMS encoding software can be opened in two ways:

1. Click **start** on the taskbar, go to programs, select **iims** and click **IIMS**. The IIMS opening window will appear prompting the user to input the username and password for the system. The initial username and password is **iims**. The password can be changed at the Main menu.

2. Click the IIMS shortcut icon from the desktop to go directly to the IIMS opening window. Make sure you create a shortcut when you install the system. The IIMS opening window will prompt the user for the username and password.
4. **IIMS Main Window**

The IIMS main window consists of a menu bar across the top, a status bar across the bottom, a treeview control on the left and a map area on the right, which displays the current regional map. Above the map box is an abbreviated data navigation control, which can be used to change the current region. The status bar, which shows the active region and IIMS site, can be seen in the main window and all data input or entry forms.

**Main Menu**

The menu bar has six main menus: File, Edit, View, Query, Launch and Help. Clicking on a menu will display a series of sub-menus.
File Menu

The File menu has three functions:

1. The **Merge with Remote IIMS** function allows the consolidation of database from different sites. This function is limited only to system administrators.

2. The **Import function** allows the user to incorporate delimited text files, Excel files or Paradox files from external sources or other digital data formats and medium to the IIMS table. (See section on Importing Tables.)

3. **Preferences** function contains three sub-functions. The **Dropdown** function enables the user to edit the values for all dropdown menus in the entry tables. The **User Maintenance** function allows the administrators to set the allowed users of the system, including passwords. If the user level is Admin, most of the functionalities and entry forms are available. Only the query system is allowed for Users. This function protects the system from those who are not authorized to alter or add any data into the system. The **Launch Directory** function allows administrators/users to set the directories for external applications so that IIMS will automatically link with that application when the function is invoked.

4. The **Exit** function terminates or closes the IIMS software.
Edit Menu

The Edit Menu has nine categories, each of the categories has dropdown sub-level menus. The sub-level menus are the classes where encoding forms are seen once opened.

View Menu

The View menu provides a tabular view of the data encoded. Accessing forms through View menu also allows the user to encode, edit or export data to MS Excel or tab delimited format.
Query Menu

The Query menu has three functions namely SQL Builder, Predefined Query and Data Count. The SQL Builder allows the user to create a customized query using SQL (standard query language). The Predefined Query allows the user to use the pre-programmed queries in the system. The data count will provide information on the number of records encoded in each table or entry form.
Launch Menu

The Launch menu provides access to external applications such as geographic information system (GIS) software and predictive models. Once the Launch menu is clicked, an access to external applications will appear.

Help Menu

The Help menu provides assistance to encoders and users on encoding into the IIMS software and querying from the IIMS database. The help menu comes with basic folders such as Content and About. The IIMS Help menu is similar to most Windows application packages.
5. **Buttons**

Buttons are essential in data encoding. They facilitate moving from one record to another, and enable editing of records. There are two types of buttons used in IIMS software: edit buttons and navigational buttons.

### The Edit Buttons

- **Delete record** – clears the input form and deletes the currently displayed record.
- **Cancel record** – cancels the editing and clears the input form.
- **Insert record** – inserts or appends the current information into the database and allows input of the next record.
- **Post record** – appends the record into the database. The information remains on the display.

### The Navigational Buttons

- **First record** – displays the first record of the database/table.
- **Next record** – displays the succeeding record of the current form.
- **Prior record** – displays the previous record of the current form.
- **Last record** – displays the last record in the database/table.
Tab Controls

Tab controls look like notebook dividers. Clicking one of these controls gives access to subclass entry forms of a category. The arrow keys on the keyboard can also be used to access these controls.

Entry Forms and Fields

Entry fields of IIMS vary from form to form. Generally, there are two types of entry fields used in the system, namely:

1. Alphanumeric entry field, where a user can input a combination of letters, symbols and numbers. Examples are names, references, descriptions, sources, telephone numbers; and

2. Numeric entry fields accepting numbers only. Examples are date, time, year and currency exchange rates.

Some fields, however, accept only specific formats. These are for the Date (yyyy.mm.dd) and the Time (hh:mm).
An entry form with entry fields is shown below.

**Graphics Buttons**

Some entry forms require graphical maps and images. These images or graphics can be added, modified or viewed using the graphics buttons. Images or graphics should be in bitmap or jpeg formats. Maps are added under form Maps in the regional category. Some forms, however, allow addition of maps or graphics.
Memo Field

The memo field is like a miniature word processor. There are several memo field boxes found in different entry forms of the categories and sub-categories throughout the program.

6. Operation

The procedures or steps to encoding covered in the succeeding sections are for the general knowledge of the user. It is advisable for users to get familiarized with which tables should be filled in first.

The IIMS regional data category should be filled in first, since all the other categories are linked with this category. For instance, encoding for the biological and bioresources category should follow the IIMS regional data category. Some of the categories are linked with this category such as socioeconomic and monitoring data.
There are two ways to access or open the various entry forms:

1. Click Edit menu from the menu bar. Select a category and click a class. The various entry forms under that class will appear; or

2. Click any category from the tree view. Choose a class and the entry form will appear.
IIMS Region, Sites, Data Classes, Glossarial

1. Following any of the two steps described, open an IIMS code category. The default form is the Region entry form for unlocked versions. For locked versions, start encoding with the Province entry form.

2. Using a pointing device or mouse, place the cursor to the first input field: province name. Type the required data and press tab to go to the next input field. Fill in the other fields.

3. When done, click the insert button [+] to add a new record or go to the next record.

4. Enter all necessary information in the form. For additional information, refer to IIMS Forms/Tables Specifications in the Guide to Establishing IIMS.

5. When done with a certain form, press [✓] to save or [X] to cancel entries, then press tab to go to the next subclass or entry form.

6. Repeat steps 2 to 5 to fill-in the other forms.

7. To close the current form and return to the main menu, click [X] at the upper right hand corner of the window.

Note:

1. The locked version are the ones distributed to the sites in response to concerns on intellectual property and confidentiality laws of respective countries.

2. Other related forms under this category include Data Classes, Geospatial, Rivers and Bodies of Water, and Maps. An entry form example for this category (Province) is shown below.
Biological and Bioresources Categories

Fish Resources

Fish Species

1. Access the Fish Species form (Edit > Biological and Bioresource Data > Fish Resources).
2. Choose the type of species by clicking from the dropdown list.
3. Fill in required data.
4. Click the [+ ] button to continue entering data, otherwise, select [✓] to save.
5. To return to the main menu by clicking [X] at the upper right hand corner of the window.

Note: The Fish/Shellfish form must be filled in before some forms which are linked to this subclass (e.g., commercial fish value per species). The forms under this category have the same encoding procedures. For more details on the required datum for each field, refer to the Guide to Establishing IIMS.
Socioeconomic Category

Fishers Inventory

1. Access the Fishers Inventory form from (Edit > Social Economic Data > Fisheries Data). Please see sample form below.
2. Click on the insert button [+] to add a new data entry.
3. Type the required data in each of the entry form.
4. Fill in the memo field, if any.
5. When finished entering required information, click the [+] button to continue encoding other records, otherwise click the [✓] button to access the next form and save.
6. To close the form, return to the main menu by clicking [X] at the upper right hand corner of the panel.

Note: Succeeding forms in this category use a similar encoding process. Click on the tab buttons to access these forms.
Demographic Data

Population

Census

1. Access the census form using the tree view or from the Edit menu (Edit > Demographic Data > Population). The default form is Census.

2. Click on the navigation buttons to select the corresponding Province/Country, City/Municipality, and Barangay/or Community of the corresponding demographic data to be encoded. Use the tab key or the mouse pointer to go to the next input field.

3. Click the [+] button to start encoding data using this form.

4. Enter data needed for all the fields. The Guide to Establishing IIMS has more details on entry forms and fields.

5. Click the post [✓] button to proceed to the next record. Otherwise, go to the next form, or return to the main menu by clicking [X] at the upper right hand corner of the panel.

6. Select another form by clicking on any of the tab buttons.

7. To close the form, return to the main menu by clicking [X] at the upper right hand corner of the panel.

Note: The other entry forms such as Income, Employment, Vital Health, Education Statistics, Waterborne Diseases and Religion use the same encoding procedures. Use the tab button or mouse pointer to access these forms.
Institutional Data

Government

Regulatory and Permitting Agencies

2. Click the add button [+] for new data entry.
3. Click the dropdown list to select the level of government for the current entry form.
4. Use the tab key to go to the next input field.
5. Fill in all necessary information for all the fields.
6. Click the add [+] button to continue data input using this form, otherwise click on the post button [✓] to go to the next form.
7. Return to the main menu by clicking [X] at the upper right hand corner of the panel.

Note: Follow the same procedure for encoding data in the other forms under this category.
Pollution Sources Data

Land-Based Sources

Industries

1. Access the Industries form using the tree view or from the Edit menu (Pollution Sources Data > Land-based Sources > Industries). Please see the form below.
2. Use the navigation buttons to select the desired name of industry encoded under Socioeconomic Category.
3. Click the add [+ ] button for new data entry.
4. Fill in the fields with required values. Please refer to the Guide to Establishing IIMS for further details.
5. Click [+] to continue encoding records using this form.
6. Click the post button [✓ ] to save the current entry and to continue to the next form.
7. Return to the main menu by clicking [ X ] at the upper right hand corner of the panel.
River Station Inventory

1. Access the River Station Entry form using the tree view or the Edit menu (Pollution Sources Data > Land-based Sources > River Pollution). Please see the form below.
2. Use the navigation buttons to select the desired River.
3. Click the add button [+] for the new data entry.
4. Fill in the fields with required values. Please refer to the Data Collection Guide for further details on loading variables.
5. Click [+] to continue encoding records using this form.
6. Click the post button [✓] to save the current entry and to continue to the next form.
7. Return to the main menu by clicking [X] at the upper right hand corner of the panel.
Monitoring Data

Water Quality

Conventional Parameters

1. Access the conventional parameters form. Click the menu item from the tree view or use the Edit menu (Monitoring Data > Water Quality Data > Conventional Parameters).

2. Select the desired monitoring station. Use the navigation buttons and click on the tab key to go to the next field.

3. Enter the values for the field (date, time, Secchi depth and source description). Refer to the Guide to Establishing IIMS for more details.

4. Post record [✓] for Wqcpobs first before encoding data into the Wqcnvpar.

5. Click the post button [✓] to save the current entry and to continue to the next form.

6. Return to the main menu by clicking [X] at the upper right hand corner of the panel.
Note: The above encoding procedure is also applicable to the Metals and Organic Compounds forms. All other forms for the Monitoring Data category have similar procedures with the previous examples.

Physiographic Data

Oceanographic Data

Tidal Summary Data

1. Access the tidal summary form from the IIMS tree view or by using the Edit menu (Physiographic Data > Oceanographic Data > Tidal Summary Data).
2. Use the navigation buttons to select the station. If the desired Station identifier is present or empty, go to the Tidal Monitoring Station inventory form. Please see the procedures in the preceding example.
3. Click the [+button] button to add a new record.
4. Fill in fields with the required data. Use the tab key from the keyboard or mouse pointer to navigate the encoding form.
5. Click [+] to continue encoding using this form or click [✓] to go to another entry form.
6. Click on the tab key to access other forms.
7. Return to the main menu by clicking [X] at the upper right hand corner of the panel.

Tidal Monitoring Station Inventory

1. Access the Tidal Monitoring Station Inventory form from the IIMS tree view or by using the Edit menu (Physiographic Data > Oceanographic Data > Tidal Monitoring Station Inventory).
2. Click the [+] button to add a new record or fill in the station identifier field and click on the [+] button.
3. Fill in values for the fields. Use the tab key from the keyboard or mouse pointer to navigate the encoding form.
4. Click [+] to continue encoding using this form.
5. Click [✓] to save the entry and go to another entry form.
6. Click on the tab key to access other forms.
7. Return to the main menu by clicking [X] at the upper right hand corner of the panel.
Model Data Inventory

This category is an archive of the results of predictive models that are linked with IIMS. Encoding in this category can only be done through the Import facility of IIMS. All data required are based from the model scenarios performed. An example of a data entry form is shown below.
7. Import Functionality

Digital files in Microsoft Excel or tab delimited or Paradox formats can be imported to the encoding software through the Import Table Utility. To incorporate or append files from external sources or other digital data formats and medium to the IIMS database table, follow the steps below:

1. Access the Import Table Utility menu.
2. Select the target table where source file or table is to be appended.
3. Select the source drive or location of the file to be imported.
4. Click on the folder where the file is stored.

5. Click on the file to be imported, then, click Preview Table. The Preview Table will show the records that are to be appended. If there are errors or problems (e.g., if the columns of the file to be appended are not in accordance with the entry form, then the error will be prompted. Go back to the MS Excel or Tab Delimited file and fix the problem before proceeding with the file import. One can also view the error by clicking on the view button of the Key Violation Table Name or Problem Table Name.
6. If there are no problems encountered, click the **Execute Merge** button. The system will prompt you with 'Importing Table done,' such as the one shown below.
7. Once the [OK] button is clicked, the records that were imported will be shown at the upper panel.
1. Make sure that the look-up tables are filled in. The look-up table is where the table to be imported is linked. For instance, the look-up table for Municipality/City is Province.

2. Make sure that the key or must field are filled in.

3. Avoid duplication of entries in the key or unique fields. These are record numbers, longitudes and latitude values, dates and time, name of provinces, cities, municipalities and communities, etc. The unique fields for each table are shown in the Guide to Establishing IIMS.

4. Follow the order of fields as sequenced in the IIMS encoding software. To make sure that the order of fields or columns is correct, go to View, select the entry table, and import to Excel or Tab Delimited format.

5. When an error is prompted, try to look for the reason why data are not accepted. Most of the errors in importing are due to wrong or inconsistent formats of the data being encoded with IIMS or key duplication errors as mentioned in #2.

6. When importing MS Excel files, make sure to close the file first, otherwise a share violation error will be prompted. If this error occurs, close the import facility and go to Excel, close the file under consideration and proceed with importing.

7. There is no need to remove the row for column headings when importing MS Excel files. In tab delimited file, however, make sure to remove the row of the headings and the record should end with a return carriage.

8. Make sure that the following are in string format: date, time and Station ID.

9. The data format for each column is very important, and these must be followed.

10. Do not discard data that were not imported. These are equally important. If the data being imported is not accepted, take note of them. Check the format, key violation errors or its link to other tables.

11. MS Excel or tab delimited formats cannot handle graphics or illustrations. Make sure that illustrations are saved in another file (jpeg or bitmap) and manually encode them through the entry forms.

12. For data using commas (,) to signify decimal places (.), change these to decimals first before importing. The comma format will not be accepted by the system.
8. Query Functionality

There are two ways to use the query system of IIMS: SQL (structured query language) and predefined query. SQL allows the user to specify the tables and fields needed in a report or graph. SQL allows more flexibility but requires familiarity with the linkages between forms or tables. One has to know which attribute/identifier or key links one table with another. The predefined query system allows the user to produce reports or graphs in a form that is available in the IIMS.

SQL Builder

The SQL builder allows the user to generate output (textual or graphics) from several tables. Data can be specified depending on what you want to appear in the report by joining two or more tables where the data are stored. However, to do so, one must be familiar with the linkages among the tables being considered. Linkages are in a form of common fields or identifiers in each table. If there are more than two tables, join two tables at a time and identify common fields.

For instance, one wants to produce a table and a graph on the population of the Province of Bataan, then Balanga City in 1995 and 2000. The sources of data are the following tables: Province, City/Municipality, Community or Barangay, and Census.

Steps:

Adding/Selecting Tables

1. Click Query from the main menu, then select SQL Builder.
2. Select tables where the data to be generated will be taken. Click the Add Table button, select the category and the class, then click Select.
3. Continue selecting until all the tables are selected. Once a table is selected, a window will appear in the panel as shown below. If you have selected four tables, four windows will be shown representing each table.

4. Select the fields that you want to appear in the report by clicking the name of field. In the example, selected from the tables were Province in prvcntry; Municipality_City in muncity; barangay in barangay; tot_population, Male_population, Female_Population and datayear from Popcens. The fields selected will appear in the lower panel.
Joining the Selected Tables

5. Join the tables by dragging the common field of the first table to the table to be adjoined. Always include Site_No as part of the common field. Determine whether the tables to be joined are 'INNER JOIN', 'LEFT JOIN' or 'RIGHT JOIN'.

If there are left and right tables, Include Unmatched Records will not be activated and Inner Join will automatically appear at the second column. Inner Join is used when there is a corresponding record or data to be matched from the right and left tables. In the example, join prvcntry with muncity through Site_No and Province_No; muncity and barangay through City_Mun_No and Site_No; and barangay and Popcens through Barangay_No and Site_No.
6. To check the SQL, click the **SQL button**. One can still edit the SQL in this panel. The SQL panel has options whether to import, save, run the query or close to go back to the previous menu.

The Query can be imported to other software applications or saved for future use.

![Image of SQL panel](image1)

**Executing the SQL**

7. To view the results of the query, click the **Execute button** at the SQL panel or the Execute button at the add table panel. The one below is the table resulting from the examples given above:

![Image of SQL results](image2)
8. Criteria can be applied to a certain field to limit the query. In the example, if one focuses on Balanga, type across Municipality/City field under criteria = “Balanga”. This means that the query will only be limited to the records corresponding to Balanga.

![Image of IIMS SQL Builder](image)

The result of the query would look like:

![Image of IIMS results](image)

Exporting Results of Query

9. To export the results of the query to other applications or formats, such as MS Excel, MS Word or text delimited format, click on the corresponding icon for application/format.
Generating Graphs and Textual Report

Using the previous example, to generate a bar graph of the male and female population for Balanga in 1995 and 2000 the steps are:

10. To generate graphs out of the result of the query, click **chart**. A View Chart panel will be prompted once the chart button is clicked.

11. In the Chart tab, click the **Series** button. A window on Chart Series will appear. Click the **Add** button and select the **Series Type**.

   Then key in the name of the series. Select the appropriate output fields for each series. The Label Field is the X axis and X value Field is the Y axis.
Once selected, click **Refresh**. Follow the same procedure in setting other series.

12. Customize the graph by click the toolbar button. An **Editing Chart** window will appear showing the series added to the chart.
13. Series Properties options

a. Format
   The format tabs customize the type of appearance of the chart such as style of a chart, the color, pattern, etc. Depending on the type of chart, this panel will allow modifications with chart characteristics.

b. General
   This tab allows one to show legend of each series, format of the marks such as those in values and percent. Precision desired can be set, such as if one wants to have the percent format or the two decimal place format (type 0.00).

c. Marks
   This allows removal of marks or labels of the series by checking/unchecking the visible field. To remove the default setting, uncheck the visible button. This tab will also show the type of marks or labels shown, such as percent, value, value and percent, etc., as shown under the style panel of the table.
14. The Chart Properties options

a. Series
Under this tab, chart types of the graph can be changed by clicking the Change button. The TeeChart Gallery window shows the other possible chart types. The name of the series can also be changed by clicking the Title button.

b. General
In this tab, charts can be print previewed, with options for zooming, scrolling and margins.
c. Axis

This allows the modification of graph axes — its scales, titles, labels, tick marks, minor tick marks and axis positions. To modify the axis, the ‘Visible’ checkbox must be enabled. Select the axis to be modified such as left, right, bottom and top.

1. Scale
   Scales enables the setting of the minimum and maximum values of the scale and axis appearance. This also allows presenting data in a normal/logarithmic or an inverted mode.

2. Title of Each Axis
   This allows for the customizing the title of the X and Y axes. Click the Text tab to modify the font and color.
3. Labels

This allows for the customizing of axis labels, including size, orientation and formats. For instance, if long words or characters are labeled in the X axis, one can set the angle of the label to 90°.

4. Ticks, Minor and Position

Other options include tick marks, minor tick marks and position of the axis.

d. Title

The title of the chart or graph can be typed and modified (font and font size, border and others) in this panel.

If the dropdown option is clicked the following selection appears: Title, Subtitle, Subfoot and Foot. The Foot
option enables footnotes such as the source of data or any remark concerning the graph.

e. Legend
This enables the customizing of a chart’s legend such as positions (left, right, bottom or top), frames, colors, font styles and sizes. The legend can also be removed here.

f. Panel
Changes in a chart’s background properties, such as borders, colors and background appearance (back image, gradient, etc.).
g. Pagination
The number of points of the X axis can be set in this tab. For instance, in the example, the number of points is set at 2.

h. Walls
This tab allows the setting of color, thickness and boarder of the walls of the chart.

i. Dimensions
This sets the chart view to 3-D, etc. The position of the chart, such as its elevation, rotation, horizontal and vertical offset, perspective and tilt, can also be modified.
15. Once all the desired properties of the chart have been modified, one can view the chart by clicking the **Chart Window** button.

![Chart Window](image1)

16. Textual or tabular report can be generated from the query by clicking on the Report menu of the SQL. A 'Generate Report' panel is shown, allowing users to put a table title and the headings of each column, the paper size and orientation. The report can be exported to MS Excel, MS Word or Text file formats.

![Generate Report](image2)
Predefined Query

The predefined query does not provide flexibility but it contains suggested charts and reports that can be generated. The predefined query can be applied in environmental profiling, risk assessment, preparation of coastal strategy and action plans.

There are seven categories of queries identified under the predefined query system:

- Socioeconomic
- Waste management
- Rivers
- Environmental quality
- Tissue analysis
- Biological resources
- Groundwater
Selecting a Query

To initiate a query, click the desired query, select the category and the output option. Once the output option is clicked, output fields and required parameters will appear. Upon clicking the level of query under the required parameter, the optional conditions will appear as shown below. If all the optional conditions are selected, click on the query data button to execute the query. If only several conditions are applied, select those conditions (say 2000, as shown), then click the query data button.

The selections can be changed by clicking the reset button. Some queries require only category, output option and level of query. Once the query data button appears, the query is ready to be executed.

Modifying X and Y Axes

At the lower portion of the panel, a default title of the chart and the titles of the X and Y axes are displayed. These can be modified when the chart button is clicked. To modify the general properties of a chart, follow the steps identified under the SQL system.
Querying Data

Once desired modifications have been done, click the query data button. The following is a query result sample:

Generating Tabular Report

The tabular report can be exported to MS Excel or MS Word or a text file and also be generated using the data generation report of IIMS.

The title of the report and the header for each column can be modified. Tabular reports can accommodate more than a hundred columns.

For steps in modifying tabular reports, refer to the SQL system section.
9. **Linking IIMS to External Software Applications**

In order to expand the functionality of IIMS in performing spatial and temporal analysis, it can be linked to some external software applications such as predictive modeling and GIS. At present, it is linked with the SealInfo predictive model, ArcView 3.x and Manifold 5.5/6.0.

**Connecting IIMS and GIS through Data Sources Open Database Connectivity (ODBC)**

1. In the Windows Control Panel, click ODBC (Windows ‘98) or administrative tools (Windows XP/Windows 2000). If using Windows XP, select data source, ODBC after clicking Administrative Tools.
2. Click the **Add** button on the ODBC Data Source administrator.

3. Select the Paradox driver, then click **Finish**.
4. In the ODBC Text Setup, unclick the current directory, then click the **Select Directory** button. Select the directory of the *iims dat* folder, then select **OK**.

![ODBC Text Setup](image)

**Setting the Launch Directory**

1. Make sure that the application software is installed in your computer.

2. Open IIMS as described in Section 3. Opening IIMS Encoding Software. In the File menu, click **Preferences > Launch Directory**, then change the directory of the external software in the Launch Path panel.

![IIMS - Integrated Information Management System](image)

3. Choose the desired application in the **Launch Menu**. Once the application software is envoked, operate the software as usual.
Linking with a Predictive Model: SealInfo

The SealInfo predictive model is only available in Manila Bay. Sites with predictive model softwares can have these linked with their respective IIMS, however, the RPO has to be notified so that the appropriate link can be programmed. As an example: once the Manila Bay predictive model is accessed, the SealInfo Window shows the Manila Bay grid as a default window. The user can now operate the system. For more details, please refer to the SealInfo Users' Manual.

'SealInfo is a Windows program for geo-referenced display of model outputs as animated time-series of scalar fields and for static display of statistical summary field' (SealInfo User Manual).
Linking with ArcView 3.x

1. Once ArcView is clicked from the Launch menu, ArcView will open the file specified in the Launch path.
2. Resize the window by using the restore and maximize buttons and the mouse buttons:

3. By resizing the window, two window objects (the Project and View windows) can be viewed.
4. Select each window. Notice that the menu and button bars changes as you shift from one window to the other.
5. In making a link to IIMS, set up SQL Connect by following the steps below:

a. From the Project Window, select SQL Connect.

b. Once the SQL Connect window opens, select iims from the dropdown list, then click Connect.
c. When the list of IIMS tables appears, select the desired table to be linked with ArcView and the columns/fields to be included in the output table by double clicking the fields. After selecting the table and the fields, put the desired name of table in the output table field. Then click the **Query** button. If an additional table is needed, repeat the procedure.

6. Once the **Query** button is clicked, the Table window will appear. Take note that there are three windows displayed on the screen: project, view and table. Close or minimize the **SQL Connect** window.
7. Activate the **View** window. To view the data on the map, click the **View** window. From the menu bar, go to view and select **Add Event Theme**.

8. An Add Event Theme window will appear. Select the connecting fields between IIMS and GIS. In the example, X field is Longitude, and Y field is Latitude. Then click **OK**.
9. The event theme (Dumpsite) will be shown in the view window. Select by clicking the image. The points will now appear in the map.

10. To display information of each point, click the **Information** icon and click a point under the dumpsite theme.
Opening Tables of the View Window

11. Open the tables of the View window by going to the menu bar or the button bar. In the button bar, look for the Open Theme Table icon and click it. Once you click on the button, its specific task will be displayed. From the menu bar, select Theme > Table.
Joining Two Tables

12. Two or more tables can be linked as long as they have common fields.

13. From the Tables, select the common fields by going to the menu bar and selecting the table. Then select the link.
14. The two tables are now ready for query. Go to \textit{Table}, select \textit{Query}, once the query field opens, you have fields and the value of the tables to start with.

15. Save the project.

16. To further modify the .apr files, refer to the \textit{ArcView Manual}. 
10. Definition of Terms

Attribute — a discrete element of data; not usually broken down into a smaller unit; it describes an entity and contains the entity’s data to be stored; and it becomes a column in a table.

Data — a general term meaning the numbers, facts, letters and symbols processed by a computer or a communication system to produce information.

Database — an organized collection of related files or tables for a common purpose.

Entity — something in the real world that is represented in a data model and about which data must be stored. It is a basic building block in a data model.

Information — data transformed into form and content relevant to a particular situation.

Instance — a particular occurrence of an entity.

Many-to-many relationship — A relationship between two entities in which one instance in the first entity can be related to many instances in the second entity, and one instance in the second entity can be related to many instances in the first entity.

One-to-many relationship — A relationship within a single entity in which one instance in the entity can be related to many instances in the same entity.

Primary key — an attribute selected as a unique identifier of a row in a table. Usually, it is one or more of the attributes of an entity that uniquely distinguishes that entity.

Relational database — a database consisting of relations or tables.

Relational database management system — a software that organizes, manipulates and retrieves data stored in a relational database.
10. Definition of Terms

Attribute — a discrete element of data; not usually broken down into a smaller unit; it describes an entity and contains the entity’s data to be stored; and it becomes a column in a table.

Data — a general term meaning the numbers, facts, letters and symbols processed by a computer or a communication system to produce information.

Database — an organized collection of related files or tables for a common purpose.

Entity — something in the real world that is represented in a data model and about which data must be stored. It is a basic building block in a data model.

Information — data transformed into form and content relevant to a particular situation.

Instance — a particular occurrence of an entity.

Many-to-many relationship — A relationship between two entities in which one instance in the first entity can be related to many instances in the second entity, and one instance in the second entity can be related to many instances in the first entity.

One-to-many relationship — A relationship within a single entity in which one instance in the entity can be related to many instances in the same entity.

Primary key — an attribute selected as a unique identifier of a row in a table. Usually, it is one or more of the attributes of an entity that uniquely distinguishes that entity.

Relational database — a database consisting of relations or tables.

Relational database management system — a software that organizes, manipulates and retrieves data stored in a relational database.